Pohelper - Plugin for geany

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Pohelper - Plugin for geany

L18L
Thanks to forum member zygo who pointed me to:
-----------------------------------------------------------------
Plugins for Geany:
About

Translation Helper is a plugin for Geany that improves the support for GetText translation files, by providing various features specific to this format and to translators.
Features

    Navigation between all, untranslated or fuzzy messages;
    Reformatting of the translation (reflow);
    Toggling the fuzziness of a translation;
    Pasting of the untranslated string to the translation;
    Automatic updating of the translation metadata.
-----------------------------------------------------------------

Activate it via geany > tools > plugin manager  tick "Translation Helper" !

Not there?
It is easy to compile:

load devx
download geany-plugins-1.24.tar.gz from http://plugins.geany.org/downloads.html
xarchive can extract it.
cd  into directory geany-plugins-1.24

open a  terminal in that directory and type
./configure
and press ENTER key.

cd into directory pohelper

type
make; make install
and press ENTER key.

Now close geany and open geany again.

Activate the Translation Helper" via  tools > plugin manager  tick "Translation Helper" !




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pohelper - Plugin for geany

Bert
Administrator
Looks like a very useful plugin, I want one...

It is not available in Geany in Quirky, so I tried to compile it, following your clear how-to.
I failed.  It was late last night, working in Quirky 7.0.2.. Problem was geany was not found..(!)

Now upgraded to 7.0.3, will try again later today.
Thanks for posting this and thanks to zygo too!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pohelper - Plugin for geany

L18L
Bert wrote
Looks like a very useful plugin, I want one...
I have also been trying to compile in April7.0.3:
----------------------------
checking pkg-config is at least version 0.9.0... yes
Package geany was not found in the pkg-config search path.
Perhaps you should add the directory containing `geany.pc'
to the PKG_CONFIG_PATH environment variable
No package 'geany' found
checking for GEANY... no
configure: error: Package requirements (geany >= 1.24) were not met
----------------------------

So I copied some files from successful compile in Fatdog64
and made a pet, see http://murga-linux.com/puppy/viewtopic.php?p=839413#839413 please.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pohelper - Plugin for geany

Bert
Administrator
Loading...